• Welcome to The Garden Machinery Forum. Please login or sign up.
 
amazon.com
Welcome to The Garden Machinery Forum. Please login or sign up.

August 05, 2021, 05:20:32 AM

Login with username, password and session length
Members
  • Total Members: 120
  • Latest: GSD Man
Stats
  • Total Posts: 899
  • Total Topics: 274
  • Online Today: 13
  • Online Ever: 275
  • (January 22, 2020, 07:39:54 PM)
Users Online
Users: 0
Guests: 11
Total: 11

Recent Topics

VigLink badge
amazon.com

Welcome to The Garden Machinery Forum


Welcome to the Garden Machinery Forum.  This site is here for all budding gardeners / Landscapers, domestic users and  pro users alike.  Got a problem with your Lawnmower, Strimmer, Chainsaw etc, then this is the place to ask for advice, hopefully we'll have the answers you're looking for, or one of our helpful members will share some advice.  Maybe you're not sure what new kit to purchase, I mean there's a vast array of products on the market these days, just ask, and one of us will be able to advise you.

Suggestions for the site are welcome. just post in the site feedback board.  Anyway, have fun and please jump in and chat in the forum.

Note: New boards will be added along the way, or the existing ones changed to suite our needs, but we'll have to see how to juggle things around.

Disclaimer: All user generated content, posts, and discussions, contained on TGMForum are the intellectual property of TGMForum.  We reserves the right to overwrite or replace any affiliate, commercial, or monetizable links, posted by users of TGMForum, with our own internal tracking.

Pages: 1 [2] 3 4 ... 29

Hi all,
New to the forum.
Looking for some advice please.
I got given a masport Olympic 400 by my father in law, he had managed to break one of the blades from the cylinder (then threw it away ::)Read More

1 Comment

I've had a mountfield sp185 for 3 years and I've never had a problem up until now. I've no experience in trying to repair lawnmowers so I'm hoping someone can help so I can give it a go.
The back right wheel is the side with the height adjuster on. The back left wheel keeps giving way and moving out of

...

Read More

0 Comments

Lent my mower to a friend who brought it back and said it had stopped!
Looking at it, it appears the Choke Rod is missing. Its been very difficult to find a new one (Honda dealer says 'N/A') but hopefully got a new one coming from L&S Engineering. However, cant see where it fits to on the back of the engine under the cover. Front must go to carbureter, but 'exploded diagram' in Honda manual dosnt show where each end fits to.Read More

12 Comments

Hey guys, just found this forum as I am struggling. My Simplicity 2620 ride on lawn mower has a Briggs and Stratton 20hp engine. I have checked the alternator output is ok (18 -20 volts ac). Renewed the regulator (as Briggs and Stratton test strategy showed it needed replacing) but the battery still does not charge????Read More

1 Comment

Still seeing a lot of drive issues with the latest models, it's such a shame as the rest of the machine is pretty nice, easy to work on etc.

But the rollers need another redesign in my opinion. Those cams in the outer ends of the rollers are just not up to the job, especially coupled with those plastic end caps which wear and allow the cams to oscillate and cause them to jump. Why they don't put a proper bushing or bearing in that end I'm not sure, but to me they should. Like they do on the inner ends of the rollers. Read More

0 Comments

STIHL recalls a limited production range of cut-off machines

a limited number of TS 410 and TS 420 cut-off machines were assembled with the flywheel retaining nut over-tightened which could cause the flywheel to fail and break apart. This would pose a projectile hazard to the operator or bystanders.

...

Read More

0 Comments
Pages: 1 [2] 3 4 ... 29