green-reaper

Recent Posts

Members
  • Total Members: 30
  • Latest: Robster
Stats
  • Total Posts: 251
  • Total Topics: 117
  • Online Today: 66
  • Online Ever: 101
  • (October 10, 2018, 12:23:28 PM)
Users Online
Users: 0
Guests: 2
Total: 2
VigLink badge

Show us the gardening dea...Does anyone know where I ...Variable speed verses fix...UPDATE: Christchurch gard...Make your first cut countA to Z of herbs: G is for...Grow your own rhubarbBest power attachments fo...How to Sharpen Your Chain...Battery tools on the upKit for pitchesBattle of the sizes 200 l...Question time with the UK...Making and using leaf mou...Planting spring-flowering...Stylised Hedge Trimming T...

Author Topic: Briggs & Stratton Carburettor problem  (Read 815 times)

Offline guytonr

  • Newbie
  • *
  • Posts: 1
    • View Profile
Briggs & Stratton Carburettor problem
« on: November 13, 2017, 11:53:33 AM »
Good day, I am a novice mechanic and don't tend to do it very often.  I have a Westwood T1800h and due to running out of fuel, after refuelling it the engine begun to hunt due to dirt in carb.  I duly removed carb and cleaned out by removing the few screws there are, wiping and replacing them and sure enough there were bits of dirt in emulsion tube, this was the only dirt I found. As the bonnet was off I decided to remove petrol tank and clean out also. On putting back together the engine only turns over without firing, there is fuel in the fuel bowl but the plugs were not wet so I am suspecting that fuel is not getting through the carb.  Does anybody have any ideas what the issue could be??? Could it be air getting in somewhere, does it need bleeding or does the emulsion tube or other crews have to be replaced in a certain way to work? I am at a loss!  Many thanks in advance. Regards, Ross



Offline Mick

  • Administrator
  • Full Member
  • *****
  • Posts: 134
    • View Profile
    • Guitarist Guild
Re: Briggs & Stratton Carburettor problem
« Reply #1 on: November 13, 2017, 05:44:27 PM »
Hi Ross, and welcome to TGMF.

Are you sure the choke is going on properly?  Wonder if when refitting the carb you might have disturbed the choke linkage in such a way it's not going on as it should.