TGMForum
Welcome to TGM Forum. Registration is easy and free, why not jump straight in and post.

Recent Posts

Members
Stats
  • Total Posts: 2,089
  • Total Topics: 784
  • Online today: 39
  • Online ever: 275 (January 22, 2020, 07:39:54 PM)
Users Online
  • Users: 1
  • Guests: 31
  • Total: 32
  • Mick
  • Google

Hyundai Surging

Started by Taz, May 18, 2024, 08:54:44 PM

Previous topic - Next topic

Taz

Hi

I have a Hyundai 510sp lawnmower that is surging and I cannot figure out why. I've changed the carburettor, installed new gaskets, checked the fuel hose and filter, installed new air filter. Governor arm and spring looks fine. Still surging and driving me crazy.

Longshot, but could it have anything to do with the pull cord rapidly deteriorating and breaking?


Mick

Hi Taz, and welcome to TGMF.

Sounds like it still has a carburettor issue. In a lot of cases where the engine hunts / surges it's the idle circuit of the carb that causes it. The little jet in the top of the carb in your case. 

Where did the replacement carb come from, was it a OEM one, or a generic one from Amazon or ebay etc?

I ask because although some sites state they are compatible with certain models, and to a point this is true as far as the fit is concerned, that doesn't mean it has the correct size jets inside for the size of the engine.

Normally when a customer has changed the carb and brings it to me for repair because it still won't run correctly I ask them for the old carb and work on that. At least you know it's right for the engine.

Check the fuel flow from the tank, pull the pipe off the carb end and check. And while you have the pipe off, make sure the fuel cap is letting air in, so the fuel can flow out. Tighten / loosen cap and check flow from the end of the pipe.
My websites
TGMForum Youtube Channel Please subscribe https://www.youtube.com/@TGMForum
Guitarist Guild

Taz

Hi, thanks for the welcome

I bought the new one from here, which seems the only place for Hyundai parts
 https://power-spares.co.uk/1142172-carburetor-Assembly/

I cleaned as best I could the old one, several times, with carburettor cleaner. Poked all the holes etc. I also bored out the air and fuel jets a bit.

The hose is clear, I can see daylight through it. Fuel filter is also clear. I couldn't find any vent in the cap. This is it: https://power-spares.co.uk/1149228-genuine-replacement-fuel-cap-connecting-rope/

I started to cut the grass with it surging yesterday as it's in desperate need. Each time I had to restart the machine I had to prime it first. I thought it would have been fine once warmed up. The cord broke before I could complete it.

Thank you

Mick

It's definitely starving of fuel then, or it has a air leak between carb and engine.

Is the fuel fresh, I mean freshly purchased? It goes off so quickly these days.  I would still check the flow from the tank, making sure the cap isn't causing a vacuum and stopping the fuel.

And also make sure all the gaskets are correct and fitted the right way around as this can cause problems.
My websites
TGMForum Youtube Channel Please subscribe https://www.youtube.com/@TGMForum
Guitarist Guild

Taz

I put fresh fuel in the day it started happening

There's almost no where for a leak between carb and engine, it's a gasket, some sort of heat plate and a hard plastic spacer. (Picture)

The hole in the rubber bit under the cap is clear but cannot find another hole in the outside of the cap. With the cap off it still surges

I think the gaskets are the right way, they don't obstruct the chamber .

I can see light through the fuel hose with some slight bending, there are no kinks in the hose.

Here's a vid of what it's doing https://photos.app.goo.gl/zLUyKN5RkH20240519_132827.jpgVfzcW57

The spring and arm look okay to me but I could be wrong

Taz

The governor bits

Mick

I can safely say it's not the governor, it would just rev its self to death if set incorrectly, or hardly rev at all if set the other way.

The fact that it's surging means the governor is working.  ;)
My websites
TGMForum Youtube Channel Please subscribe https://www.youtube.com/@TGMForum
Guitarist Guild

Mick

Forgot to say, I can't view the video of the mower unfortunately, it just says this,

"Dynamic Link Not Found
Short URL (https://photos.app.goo.gl/zLUyKN5RkH) not found

If you are the developer of this app, ensure that your Dynamic Links domain is correctly configured and that the path component of this URL is valid."
My websites
TGMForum Youtube Channel Please subscribe https://www.youtube.com/@TGMForum
Guitarist Guild

Taz

https://photos.app.goo.gl/Qjvaos8GiLvwG5zt6

hopefully this time.


Could it be the house even though it looks clear?

Mick

Yep, I see the vid now.  Well all I can say is it's still got a fuel issue. So anything's possible.  My bet is still a carb issue.

I have an example of a machine where the customer sent in a machine he'd tried to fix, new carb fitted and it wouldn't run.  This video shows his old carb which I cleaned and refitted. Gave him his new carb back in a bag.  ;)


https://www.youtube.com/shorts/pAwoG9C88No
My websites
TGMForum Youtube Channel Please subscribe https://www.youtube.com/@TGMForum
Guitarist Guild

TGMF is a participant in the Amazon EU Associates Program. This affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to products on Amazon.